egghelp.org community Forum Index
[ egghelp.org home | forum home ]
egghelp.org community
Discussion of eggdrop bots, shell accounts and tcl scripts.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

help in utf8 in eggdrop v1.8.4

 
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Requests
View previous topic :: View next topic  
Author Message
Arnold_X-P
Op


Joined: 30 Oct 2006
Posts: 191
Location: DALnet - Trinidad - Beni - Bolivia

PostPosted: Thu Oct 17, 2019 8:51 pm    Post subject: help in utf8 in eggdrop v1.8.4 Reply with quote

good night I would like to know how to use the utf8 in eggdrop v1.8.4 try to use it but it does not work for me, someone who helps me configure for my bot to use the utf8. try to recompile it and use tcl but it doesn't work.....Thanks
_________________
Very Happy thanks to that they help, that others learn Very Happy
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Cadaver
Voice


Joined: 04 Dec 2018
Posts: 18
Location: México

PostPosted: Fri Oct 18, 2019 11:43 am    Post subject: Reply with quote

Maybe ... If you wrote your questions in Spanish and English we could understand you better, because you dont use punctuation marks and your questions are not understandable.

If i am correct and i understood you ... You need to change the encoding to utf-8, for that you need to edit file src/tcl.c and search these lines:

Code:
if (encoding == NULL) {
  encoding = "iso8859-1";
}


Change for:

Code:
encoding = "utf-8";


Then compile and run.
_________________
-- [ Soluciones Hosting ] -- [ ElChatIRC ] --
Back to top
View user's profile Send private message Visit poster's website
Arnold_X-P
Op


Joined: 30 Oct 2006
Posts: 191
Location: DALnet - Trinidad - Beni - Bolivia

PostPosted: Tue Oct 22, 2019 4:00 pm    Post subject: Reply with quote

That way does not work anymore I tried, it only works in older versions
_________________
Very Happy thanks to that they help, that others learn Very Happy
Back to top
View user's profile Send private message Send e-mail Visit poster's website MSN Messenger
Display posts from previous:   
Post new topic   Reply to topic    egghelp.org community Forum Index -> Script Requests All times are GMT - 4 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Forum hosting provided by Reverse.net

Powered by phpBB © 2001, 2005 phpBB Group
subGreen style by ktauber